Kubernetes Performance Degradation

Incident Report for IONOS Cloud

Resolved

We are marking this incident as resolved. All services behave normally.
Posted Dec 18, 2025 - 19:31 UTC

Monitoring

We have restored the affected control plane cluster. We are now restarting related API servers and then monitoring the system for any anomalies before marking the incident as resolved.
Posted Dec 18, 2025 - 17:20 UTC

Identified

We have traced the issue back to a specific control plane cluster. Customers using the affected control plane cluster will currently be unable to deploy changes. Our Kubernetes Team is working towards restoring the affected cluster.
Posted Dec 18, 2025 - 17:03 UTC

Investigating

We are currently investigating degraded performance in our Kubernetes service.
Posted Dec 18, 2025 - 16:51 UTC
This incident affected: Location FR/PAR (Managed Kubernetes), Location US/MCI (Managed Kubernetes), Location DE/TXL (Managed Kubernetes), Location DE/FRA (Managed Kubernetes), Location DE/FKB (Managed Kubernetes), Location GB/LHR (Managed Kubernetes), Location US/EWR (Managed Kubernetes), Location US/LAS (Managed Kubernetes), Location ES/VIT (Managed Kubernetes), Location GB/BHX (Managed Kubernetes), and Location DE/FRA/2 (Managed Kubernetes).