Cloud Support: Telephone Support temporarily unavailable

Incident Report for IONOS CLOUD

Resolved

Phone Support is now available again
Posted Jun 13, 2026 - 21:13 UTC

Identified

IONOS Cloud Support is temporarily unavailable via phone. We ask Customers and Partners to contact Cloud Support via DCD Form and Email, instead.
Posted Jun 13, 2026 - 13:50 UTC
This incident affected: Cloud Support.