Intermittent Issues with IONOS Cloud Telephon Support

Incident Report for IONOS Cloud

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 12:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2026 - 12:42 UTC

Investigating

We are currently investigating intermittent issues with IONOS Cloud Support Telephone Line. While mostly outgoing calls are affected, we ask customers to use support@cloud.ionos.com if the team cannot be reached correctly via phone.
Posted Jan 30, 2026 - 09:56 UTC
This incident affected: Cloud Support.