Suspected Issues with USt- / VAT ID verification

Incident Report for IONOS Cloud

Resolved

This incident has been resolved, and all affected customers have been contacted directly via email.
Posted May 13, 2026 - 06:56 UTC

Identified

We can confirm that these emails were sent out in error.

There are no customer 'to-do's / calls-to-action, and we will send out an informational update to all affected customers as soon as possible.
Posted May 12, 2026 - 14:38 UTC

Investigating

We are aware that, starting this morning, multiple customers have received an automated email from our Accounting Team advising that their Umsatzsteuer- / VAT ID numbers could not be verified.

We are currently investigating this issue, and expect to send out follow-up emails to the affected customers once we know more.
Posted May 12, 2026 - 08:50 UTC
This incident affected: Global Services (Accounts and Billing).