Managed Kubernetes: Service Degradation for Control Planes in FRA

Incident Report for IONOS Cloud

Resolved

We are marking the incident as resolved, as no further anomalies were detected. The root cause was a transient latency issue in one of the redundant CoreDNS pods, which led to kube-apiservers being unable to discover etcd instances in time. We are currently developing better mitigation options for the excessive NXDOMAIN requests observed during the incident.
Posted Apr 01, 2026 - 20:18 UTC

Monitoring

All affected Control Planes have recovered. We are currently monitoring the affected clusters for further anomalies.
Posted Mar 31, 2026 - 13:10 UTC

Investigating

We are currently investigating service degradation for Control Planes of some Kubernetes clusters in the FRA DC.
Posted Mar 31, 2026 - 12:22 UTC
This incident affected: Location DE/FRA (Managed Kubernetes).