Cloud Support: Telephone Support temporarily unavailable

Incident Report for IONOS Cloud

Resolved

Phone Support is now available again
Posted Jul 02, 2026 - 13:50 UTC

Update

We are continuing to investigate this issue.
Posted Jul 02, 2026 - 07:01 UTC

Investigating

IONOS Cloud Support is temporarily unavailable via phone. We ask Customers and Partners to contact Cloud Support via the DCD Form or Email, instead.
Posted Jul 02, 2026 - 07:00 UTC
This incident affected: Cloud Support.