Cloud Support: Telephone Support reduced capacity

Incident Report for IONOS CLOUD

Resolved

We managed to get back to normal capacity, so Support is back to normal availability.
Thank you for the patience.
Posted Aug 20, 2026 - 08:18 UTC

Update

The situation is still unchanged, so best would be to please reach out via email.
Posted Aug 17, 2026 - 13:31 UTC

Identified

There may be periods of increased waiting times when calling IONOS Cloud Support by phone. We ask Customers and Partners to contact Cloud Support via the DCD Form or Email, instead.
Posted Aug 14, 2026 - 14:50 UTC
This incident affected: Cloud Support.