Managed Kubernetes - Intermittent Control Plane Unavailability

Incident Report for IONOS CLOUD

Update

Our plans for further horizontal scaling of the control plane are progressing. We expect to be able to do a dry run and further testing within the next hours, before we proceed with migrations.
We aim to finish work on horizontal scaling until EOD.
We are rolling out memory configuration improvements in parallel.
Posted Aug 04, 2026 - 16:23 UTC

Update

We are currently rolling out memory scaling measures to address recurring stability issues during compaction operations on the affected etcd clusters. Additionally, we are planning to roll out further horizontal scaling for the affected clusters today.

We will provide another update once these measures have been applied and we can assess their impact.
Posted Aug 04, 2026 - 14:37 UTC

Update

During a service rollout today, a subset of control planes experienced temporary restarts. Affected customers may notice brief API unavailability while these control planes recover. The team is monitoring the recovery.

Separately, work on improving infrastructure capacity and load distribution continues as described in our initial update.

We will post another update once the affected control planes have fully stabilized.
Posted Aug 04, 2026 - 13:14 UTC

Identified

We are aware of intermittent control plane unavailability affecting a subset of Managed Kubernetes customers. Affected customers may experience API call failures, deployment timeouts, and temporary disruption of cluster management operations.

Our engineering team is actively working on both immediate mitigations and longer-term architectural improvements.

Several mitigations have already been deployed, including maintenance schedule optimization, compaction regression fixes, and storage performance improvements. Additional measures - including infrastructure migration, dedicated event etcd clusters, improved load balancing, and horizontal scaling - are in progress.

We are providing regular updates on this page. Customers experiencing issues are encouraged to subscribe to this incident for timely notifications.
Posted Aug 04, 2026 - 10:24 UTC
This incident affects: Location FR/PAR (Managed Kubernetes), Location US/MCI (Managed Kubernetes), Location DE/TXL (Managed Kubernetes), Location DE/FRA (Managed Kubernetes), Location DE/FKB (Managed Kubernetes), Location GB/LHR (Managed Kubernetes), Location US/EWR (Managed Kubernetes), Location US/LAS (Managed Kubernetes), Location ES/VIT (Managed Kubernetes), Location GB/BHX (Managed Kubernetes), and Location DE/FRA/2 (Managed Kubernetes).