DCD Frontend: Issues editing VDCs

Incident Report for IONOS Cloud

Resolved

We are marking this incident as resolved. The Issue was caused by a faulty DCD release, which was rolled back by the responsible team.
Posted Mar 04, 2026 - 11:14 UTC

Monitoring

Our DCD Front‑end team has identified an issue introduced by a recent release. A rollback was performed, and customers who were unable to edit their VDCs and were confronted with an “In Progress/Pending” status should now be unblocked.

We are actively monitoring the situation.
Posted Mar 04, 2026 - 09:54 UTC

Investigating

We are actively investigating reports of frontend problems when attempting to edit VDCs through the DCD UI.
Posted Mar 04, 2026 - 08:51 UTC
This incident affected: APIs and Frontends (Data Center Designer (DCD)).